Skip to content

MkDocs

Setup local dev environment

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
MKDOCS_VERSION="1.0.4" && \
MKINCLUDE_VERSION="0.5.1" && \
PYMD_EXT_VERSION="5.0" && \
PYGMENTS_VERSION="2.2.0" && \
MATERIAL_VERSION="3.0.4" && \
sudo apt update && \
sudo apt install -y python3 python3-pip && \
pip3 install --user --upgrade pip && \
pip3 install --user \
  mkdocs==${MKDOCS_VERSION} \
  markdown-include==${MKINCLUDE_VERSION} \
  pymdown-extensions==${PYMD_EXT_VERSION} \
  pygments==${PYGMENTS_VERSION} \
  mkdocs-material==${MATERIAL_VERSION}